By | May 5, 2012

As reported yesterday with reference to the pod2g’s tweet that he is running 5.1 untethered jailbreak on iPhone 4, there came the question whether the new jailbreak will be applicable for all devices or not. Even some people commented that 5.1 iPhone 4S tethered is enough and no need for untethered.

Pod2g has beautifully replied to these people by saying “Don’t forget there are Apple TV3, 4S, iPad2 and iPad3 users out there! and lot of these users got 5.1 out of the box” So this statement clearly reveals to us that the jailbreak for 5.1 which pod2g is going to release hopefully soon, will surely be compatible for all idevices currently available in the market.

The new 5.1 untethered jailbreak will be compatible with:

  • iPhone 4S 5.1
  • iPhone 4 5.1
  • iPhone 3Gs 5.1
  • iPad 3 5.1
  • iPad 2 5.1
  • iPad 1 5.1
  • ipod Touch 3G 5.1
  • iPod Touch 4G 5.1

If you are willing to jailbreak 5.1 iPhone 4S now you can follow this tutorial but remember this is a tethered jailbreak for iphone 4S.

Read below tweets and guess yourself.

You can follow pod2g Here for latest tweets and updates on ios 5.1 jailbreak.

5.1 jailbreak for all devices

Don’t forget to join my blog below so that the updated news can be directly send to your mailbox on daily basis.